Informática y Programación Escuela de Ingenierías Industriales y Civiles Curso 2010/2011

Tamaño: px
Comenzar la demostración a partir de la página:

Download "Informática y Programación Escuela de Ingenierías Industriales y Civiles Curso 2010/2011"

Transcripción

1 Módulo 2. Fundamentos de Programación Informática y Programación Escuela de Ingenierías Industriales y Civiles Curso 2010/2011 1

2 CONTENIDO Tema 1. Conceptos generales de algorítmica Tema 2. Sentencias de control Tema 3. Conjuntos dimensionados Tema 4. Programación estructurada Tema 5. Ficheros 2

3 Sentencias de control En el cuerpo de un algoritmo se especifican ordenadamente las distintas acciones de la que este se compone. En general, estas acciones se denominan sentencias o instrucciones. Podemos clasificarlas en tres tipos: sentencias secuenciales. sentencias condicionales. sentencias repetitivas. Cualquier algoritmo se puede realizar con estas sentencias 3

4 Sentencia secuencial Es el tipo de sentencia más simple, consiste en la ejecución consecutiva las instrucciones del algoritmo, es decir, secuencialmente una instrucción detrás de otra. Se puede escribir de dos formas distintas, de forma vertical una después de otra. <acción 1> // primera acción o sentencia a ejecutar <acción 2> // segunda acción o sentencia a ejecutar <acción n> // última acción o sentencia a ejecutar O de forma horizontal separándolas por comas. < acción 1 >, < acción 2 >, < acción N > Diagrama de flujo: Utilizado para expresar de forma gráfica un algoritmo. acción 1 acción 2 acción n 4

5 Sentencia secuencial Cabecera Declaración de variables Cuerpo secuencial Cierre Entrada datos Salida datos Algoritmo Cálculos variable real a, b, c, d, e, x, y Escribir( Introduzca x, y ) Leer(x,y) a = x + y b = x / y c = x - y d = x * y e = y * y Escribir(a, b, c, d, e) fin Algoritmo Inicio Leer x,y a=x+y b=x/y c=x-y d=x*y e=y*y Escribir a,b,c,d,e Fin 5

6 Sentencias condicionales Permiten controlar el flujo de ejecución. Se especifica una condición que se evalúa y dependiendo de su resultado, verdadero o falso, ejecutará una acción (o grupo de), o bien otra acción distinta (o grupo de). Tipos: Sentencia condicional simple (si, entonces, fin si) Sentencia condiciona doble (si, entonces, si no, fin si) Sentencia condicional múltiple (según, fin según) 6

7 Sentencia condicional simple Se emplea en el caso que no queramos realizar ninguna acción cuando la condición no se cumple. La sintaxis contiene las palabras reservadas si, entonces, fin si que delimitan la condición y la acción o acciones a realizar. si <Condición> entonces // <Condición> es un predicado o expresión lógica fin si <Acción> //< Acción> es una o un conjunto de acciones // a ejecutar cuando <Condición> es verdadera 7

8 Sentencia condicional simple Algunas operaciones matemáticas, como el cálculo de un algoritmo, requieren que los operadores sean positivos. Un ejemplo de uso de la sentencia condicional simple es el algoritmo que comprueba si el dato de entrada es mayor que cero. Algoritmo Mayor Cero variable real x Escribir( Introduzca un número. ) Leer(x) si x > 0 entonces Escribir( Número mayor que cero. ) fin si fin Algoritmo 8

9 Sentencia condicional doble Se emplea cuando queremos realizar un grupo de acciones si la condición se cumple y otro grupo de acciones distintas cuando la condición no se cumple. Sintaxis si <Condición> entonces si no fin si <Acción 1> <Acción 2> // <Condición> es un predicado o expresión lógica // < Acción 1> es una o un conjunto de acciones a // ejecutar cuando <Condición> es verdadera //< Acción 2> es una o un conjunto de acciones a // ejecutar cuando <Condición> es falsa 9

10 Sentencia condicional doble Como ejemplo, un algoritmo que comprueba antes de realizar la operación de división, si el denominador es igual a cero. Algoritmo Divide dos números variable real a, b, r Escribir( Introduzca los valores de las variables a y b ) Leer(a,b) si b == 0 entonces Escribir( Error: División por cero ) si no r = a / b Escribir( Resultado=, r) fin si fin Algoritmo 10

11 Sentencia condicional múltiple Las sentencias condicionales se pueden anidar, permitiendo expresar múltiples acciones dentro del algoritmo. si <Condición 1> entonces si no <Acción 1> si <Condición 2> entonces <Acción 2> si no <Acción 3> fin si <Acción 4> fin si // Se ejecuta cuando <condición 1> sea verdadera // Se ejecuta cuando <condición 2> sea verdadera // y <condición1> falsa // Se ejecuta cuando <condición 2> sea falsa // y <condición1> falsa // Se ejecuta cuando <condición 1> sea falsa 11

12 Sentencia condicional múltiple Las sentencias condicionales múltiples también se pueden expresar en forma de diagrama de flujo: 12

13 Sentencia condicional múltiple Sentencia según es una sentencia condicional cuya sintaxis compacta las múltiples condiciones que se necesitan. Sintaxis: según <Expresión> // debe tomar valores enteros o carácter caso <Valor1>: <Acción 1> caso <Valor2>: <Acción 2> caso <Valor3>: <Acción 3>... en otro caso // se ejecuta si <Expresión> toma el valor <Valor1> // se ejecuta si <Expresión> toma el valor <Valor2> // se ejecuta si <Expresión> toma el valor <Valor3> <Acción N> // se ejecuta si <Expresión> toma valor distinto a los anteriores fin según 13

14 Sentencia condicional múltiple En la sentencia según cuando <Expresión> adquiere el <Valor1> se realiza la <Acción 1>, cuando adquiere el <Valor2> se realiza la <Acción 2>, y así sucesivamente. Finalmente, en caso de tomar otro valor no especificado se realiza la <Acción N>. Diagrama: 14

15 Sentencia condicional múltiple Escribir un algoritmo que muestre un mensaje que indique si el día es laborable o fin de semana dependiendo del valor numérico introducido por teclado (de 1 a 7, siendo 1 el lunes y 7 el domingo. Cualquier otro número se mostraría un mensaje de error) Algoritmo Laborable o no variable entera dia Escribir( Introducir el numero de día de la semana: ) Leer(dia) según dia caso 1: Escribir( Laborable Lunes ) caso 2: Escribir( Laborable Martes ) caso 3: Escribir( Laborable Miércoles ) caso 4: Escribir( Laborable Jueves ) caso 5: Escribir( Laborable Viernes ) caso 6: Escribir( Fin de semana Sábado ) caso 7: Escribir( Fin de semana Domingo ) en otro caso: escribir( Error ) fin según fin Algoritmo 15

16 Ejercicios sentencias condicionales 1. Realizar un algoritmo que devuelva el valor absoluto de un número entero dado. 2. Escribir un algoritmo que indique si un número es par. 3. Escribir un algoritmo que determine si un número es múltiplo de 2 y de Realizar un algoritmo que lea dos números enteros en las variables a y b, y se asegure de guardar en la variable a el mayor de ambos. 5. Realizar un algoritmo que lea un número entero e indique si es mayor, menor o igual a Escribir un algoritmo que solicite dos números enteros y muestre el mayor de ellos por pantalla. El algoritmo indicará la situación cuando los dos números sean iguales. 7. Escribir un algoritmo que pida una calificación y la muestre por pantalla en formato Apto o No Apto según si es mayor, igual o menor que Realizar un algoritmo que calcule 1/x. 16

17 Ejercicios sentencias condicionales 9. Algoritmo para calcular 10.Realizar el algoritmo que resuelva una ecuación de segundo grado. ax 2 x y + bx + c 11.Escribir un algoritmo para resolver sistemas de ecuaciones de dos incógnitas. 12.Realiza un algoritmo que lea cinco números enteros y escriba los mayores que la media. 13.Realiza un algoritmo que lea dos números, a y b, e indique si a es mayor que b o no. = 0 ax + by = c dx + ey = f 17

18 Ejercicios sentencias condicionales 14.Realizar un algoritmo que lea tres valores enteros y muestre por pantalla el máximo y el mínimo de ellos. 15.Realizar un algoritmo que lea tres números enteros y los ordene de mayor a menor. 16.Escribir un algoritmo que solicite la calificación de un examen (un número real entre 0 y 10) y muestre por pantalla la calificación en formato Suspenso, si la nota es menor que 5, Aprobado si está entre 5 inclusive y 7 sin incluir, Notable si está entre 7 inclusive y 9 sin incluir, Sobresaliente si está entre 9 inclusive y 10 sin incluir y Matrícula de honor si la nota es igual a Escribir un algoritmo que tras leer el número del día de la semana, escriba por pantalla su nombre. 18.Escribir un algoritmo que, dado el número del mes y la información de si el año es bisiesto, muestre por pantalla el número de días del mes. 19.Escribir un algoritmo que, tras leer la fecha de nacimiento de una persona, imprima por pantalla su signo zodiacal. 18

19 Sentencias repetitivas La sentencia repetitiva, iterativa, o bucle, permite describir, con una notación compacta, la situación en la que se quiere realizar una acción varias veces dentro de un algoritmo. El número de repeticiones, también llamadas iteraciones, depende del cumplimiento de una condición. Si la condición es falsa, el procesador sale de la sentencia repetitiva y continúa ejecutando las acciones situadas a continuación de la sentencia iterativa. Tipos: mientras (mientras hacer, fin mientras) repetir (repetir, hasta que); (repetir mientras) para (para, desde, hasta, paso, hacer, fin para) 19

20 Sentencia mientras El número de repeticiones lo determina la condición escrita en la cabecera de la sentencia. La acción solo se ejecuta si se cumple la condición, es decir, si esta se evalúa como verdadera; en caso contrario, se continúa en la acción situada fuera del bucle tras el fin mientras. Sintaxis: mientras <Condición> hacer // <Condición es una expresión lógica <Acción> fin mientras // conjunto de acciones a realizar repetidamente... // el algoritmo continua aquí cuando sale del bucle 20

21 Sentencia mientras Ejemplo: Algoritmo para la clasificación de libros. Las acciones que están situadas dentro de la sentencia repetitiva se ejecutarán siempre que queden libros en la estantería (condición de la sentencia repetitiva). Algoritmo Clasificar libros mientras queden libros por clasificar hacer Coger un libro Rellenar ficha papel Pegar ficha al libro Rellenar ficha ordenador Colocar libro en pila clasificados fin mientras fin algoritmo 21

22 Sentencia mientras Ejemplo: Algoritmo que muestra los números del 1 al 100 utilizando la sentencia mientras. Algoritmo Muestra del 1 al 100 variable rentera i i = 1 mientras i <= 100 hacer Escribir(i) i = i + 1 fin mientras fin algoritmo 22

23 Sentencia repetir La condición a evaluar está situada al final de la sentencia. La acción, se ejecuta al menos una vez. Mostramos dos variantes para expresar la condición Sintaxis A: repetir <Acción> hasta que <Condición> Sintaxis B: repetir <Acción> mientras <Condición> // conjunto de acciones a ejecutar dentro del bucle // conjunto de acciones a ejecutar dentro del bucle 23

24 Sentencia repetir Ejemplo: Algoritmo que muestra del 1 al 100 utilizando la sentencia repetir. Algoritmo Muestra naturales variable entera i i = 1 i = 1 repetir Escribir(i) Algoritmo Muestra naturales variable entera i repetir Escribir(i) i = i + 1 i = i + 1 hasta que i> 100 mientras i<= 100 fin algoritmo fin algoritmo La solución es muy parecida a la ofrecida con la sentencia repetitiva mientras salvo que la condición de parada, si se utiliza la sintaxis A, varía ligeramente (ahora es i>100) al evaluarse al final del bucle. 24

25 Analogía entre sentencias repetir y mientras Relación entre el repetir y mientras Algoritmo con repetir repetir <Acción> hasta que <Condición> Algoritmo con mientras <Acción> mientras <Condición> hacer <Acción> fin mientras Utilizaremos la sentencia repetitiva repetir siempre que queramos que la acción se realice al menos una vez. En cualquier otro caso puede utilizarse la sentencia mientras. 25

26 Sentencia para Se utiliza cuando queremos repetir una misma acción un número determinado de veces. Usa una variable contadora que va desde un valor inicial hasta un valor final, realizando una iteración cada vez y modificando el contador según lo indicado en paso. 26

27 Sentencia para Sintaxis: para <Contador> desde <ValorInicial> hasta <ValorFinal> paso <valor> hacer <Acción> fin para Cuando el valor del paso no se especifica se toma el valor 1 quedando: para <Contador> desde <ValorInicial> hasta <ValorFinal> hacer <Acción> // conjunto de acciones a repetir fin para La variable <Contador> toma valores desde <valorinicial> hasta <valorfinal>, en la primera iteración toma el valor <valorinicial>. Al final de cada iteración la variable <Contador> se incrementa en 1. El bucle finaliza cuando la variable <Contador> supera el <valorfinal> 27

28 Sentencia para Ejemplo: Algoritmo que muestra del 1 al 100 utilizando la sentencia para. Algoritmo Muestra naturales variable rentera i, N para i desde 1 hasta N hacer fin para fin algoritmo Escribir(i) Note que la variable auxiliar utilizada como contador va desde un valor inicial hasta uno final, utilizando un incremento, pero no tiene que ser siempre de menor a mayor, en el ejemplo de los naturales, podemos ir desde N hasta 1 con una construcción: 28 para i desde N hasta 1 paso -1 hacer

29 Analogía entre sentencias para y mientras Construir la sentencia para con una mientras <variablecontadora> = <valorinicial> mientras <variablecontadora> <valorfinal> hacer <Acción> <variablecontadora> = <variablecontadora> + <incremento> fin mientras Cuando usar mientras o para? Se suele utilizar la sentencia repetitiva para siempre y cuando sepamos, de antemano, el número exacto de iteraciones que se van a ejecutar. En cualquier otro caso elegiremos la sentencia mientras o repetir. 29

30 Sentencia para Ejemplo: Calcular la suma de los primeros 100 números impares con la siguiente sumatoria: 100 i= 1 ( 2i 1) = Algoritmo Suma 100 primeros impares variable entera i, suma suma = 0 para i desde 1 hasta 100 hacer suma = suma + 2*i -1 fin para Escribir ( Suma=, suma) fin Algoritmo 30

31 Traza de algoritmo: suma de los primeros 10 números impares Tabla de análisis de las variables Variable Función Valor inicial Valor final i Variable contadora 1 10 suma Variable que contiene la suma del los 10 primeros impares 0 Valor resultado 31

32 Traza de algoritmo: suma de los primeros 10 números impares Tabla de la traza Algoritmo Bloque de datos Terminal i suma Inicialmente suma = suma + 2*i suma = suma + 2*i suma = suma + 2*i suma = suma + 2*i suma = suma + 2*i Suma= 100 fin de ejecución - 32

33 Sentencia repetitiva La misma acción repetitiva puede hacerse utilizando distintas sentencias: mientras, para o repetir. Algoritmo Suma 100 primeros impares variable entera i, suma suma = 0 para i desde 1 hasta 100 hacer suma = suma + 2*i -1 fin para Escribir ( Suma=, suma) fin Algoritmo Algoritmo Suma 100 primeros impares variable entera i, suma suma = 0 i = 0 mientras i <= 100 hacer suma = suma + 2*i -1 i = i +1 fin mientras Escribir ( Suma=, suma) fin Algoritmo Algoritmo Suma 100 primeros impares variable entera i, suma suma = 0 i = 0 repetir suma = suma + 2*i -1 i = i +1 hasta que i>100 Escribir ( Suma=, suma) fin Algoritmo 33

34 Sentencia repetitiva Ejemplo: Algoritmo que calcula el factorial de un número dado, con la sentencia para Algoritmo Factorial variable entera a, factorial, c Escribir ("Introduzca el número: ) Leer (a) factorial = 1 para c desde 2 hasta a hacer factorial = factorial*c fin para Escribir ("El factorial de", a, " es: ",factorial) fin Algoritmo Cómo lo haría con las otras sentencias repetitivas? 34

35 Anidamiento de sentencias Dentro de una sentencia puede haber otras sentencia y dentro de esta otra y así sucesivamente, es lo que se conoce como anidamiento de sentencias. si condición1 entonces acción1 para i desde 1 hasta n hacer acción2 si condición2 entonces acción3 fin si fin para si no acción4 fin si 35

36 Anidamiento de sentencias Algoritmo Escribir naturales variable entera num variable entera salir = 1 mientras salir <> 0 hacer //Se repite hasta que el usuario inserta 0 Escribir( Introduzca un número ) Leer(num) Escribir( Los números son:,num) para i desde 1 hasta num hacer Escribir( i) fin para Escribir( Desea salir? (0-si, 1-no) ) Leer(salir) fin mientras fin Algoritmo 36

37 Ejercicios 1. Realizar un algoritmo que escriba de veces la frase de la imagen. 2. Escribir un algoritmo que lea un número y muestre por pantalla su tabla de multiplicar. 3. Realizar un algoritmo que calcule la suma de los n primeros números naturales. 4. Escribir un algoritmo que calcule el factorial de un número dado. 37

38 Ejercicios sentencias repetitivas 5. Realizar un algoritmo que calcule el producto de dos números mediante sumas. 6. Realizar un algoritmo que calcule la división entre dos números mediante restas sucesivas. 7. Potencia de un número a través de multiplicaciones. 8. Realizar un algoritmo que lea dos números enteros, a y b, y escriba de menor a mayor los números enteros entre ellos. 9. Realizar un algoritmo que lea dos números enteros, a y b, y escriba los números enteros entre ellos de mayor a menor. 10. Realizar un algoritmo que, de los primeros 100 números naturales, escriba por pantalla los pares. 11. Realizar un algoritmo que lea dos números enteros, a y b, y escriba los números enteros entre ellos múltiplos de Realizar un algoritmo que de los primeros 200 números enteros, escriba los números pares y la media aritmética de los impares. 13. Realizar un algoritmo que, tras leer un número entero, escriba todos sus divisores. 38 Nota: La división entre reales se indica con /, la división entera con div. La función resto con mod. P.e. 3/2=1.5, 3 div 2=1 y 3 mod 2 = 1

39 Ejercicios sentencias repetitivas 14. Realizar un algoritmo que determine si un número es primo. 15. Escribir un algoritmo que lea una lista de números y determine el número de ellos que son positivos y negativos. 16. Realizar un algoritmo que, tras leer un valor entero n, muestre todos los enteros menores que dicho número que cumplan la condición de ser pares y múltiplos de tres, además de la suma de los que no cumplen dicha condición. 17. Realizar un algoritmo que lea números hasta que se introduzca el cero y escriba la media. 18. Realizar un algoritmo que, tras leer un número natural, escriba por pantalla los cinco primeros números impares que sean mayores que dicho número y múltiplos de tres. 19. Realizar un algoritmo que escriba los n primeros elementos de la serie Fibonacci, F i = F i+1 +F i+2 teniendo en cuenta que F 1 = F 2 = Escribir un algoritmo que genere la sucesión 1, 1/2!, 1/3!, 1/4!,, 1/n!. 21. Realizar un algoritmo que calcule el exponencial de un número según la siguiente aproximación: 20 i e x = x i= 0 i! 39

40 Ejercicios sentencias repetitivas 22. Dada la siguiente ecuación realizar el algoritmo que calcule el valor de x, para valores de a y b introducidos por el usuario por teclado. x = b j= 1 a i= 1 i 2 ( j + 3) 23. Realizar un algoritmo que muestra por pantalla horas, minutos y segundos, indefinidamente como lo haría un reloj en formato de 24 horas. 24. Realizar un algoritmo que, tras leer un número de horas, minutos y segundos, realice la cuenta atrás escribiendo en cada momento el tiempo restante, y finalice la cuenta al llegar a cero. 40

41 Ejercicios sentencias repetitivas 25. Escribir un algoritmo que determine los números naturales capicúas de tres cifras. 26. Escribir un algoritmo que genere la siguiente pirámide de dígitos utilizando bucles:

42 Bibliografía Fundamentos de Informática y Programación para Ingeniería. Ejercicios Resueltos para C y Matlab. Modesto Castrillón et al, Paraninfo, Introducción a la informática, A. Prieto Espinosa, A. Lloris Ruiz, J.C. Torres Cantero, McGraw-Hill, Madrid, Programación en C, Byron S. Gottfried, McGraw-Hill, Madrid (1997) - (2ª ed.) Introducción a la informática, A. Prieto Espinosa, A. Lloris Ruiz, J.C. Torres Cantero, McGraw-Hill, Madrid (1989) Una introducción a la programación. Un enfoque algorítmico. J. García Molina et al., Thomson,

Tema 7: Programación con Matlab

Tema 7: Programación con Matlab Tema 7: Programación con Matlab 1. Introducción Matlab puede utilizarse como un lenguaje de programación que incluye todos los elementos necesarios. Añade la gran ventaja de poder incorporar a los programas

Más detalles

Programación en lenguaje C++

Programación en lenguaje C++ Programación en Lenguaje C++ Objetivos Unidad Tema Subtema Objetivos VI 6.1 Metodología de la programación Metodologías Diseños de algoritmos Creación de algoritmos Entender y aplicar los pasos a seguir

Más detalles

3 ESTRUCTURAS DE CONTROL REPETITIVAS. BUCLES

3 ESTRUCTURAS DE CONTROL REPETITIVAS. BUCLES 3 ESTRUCTURAS DE CONTROL REPETITIVAS. BUCLES 3.1 Estructuras de repetición Una estructura de repetición, también llamada lazo o bucle, hace posible la ejecución repetida de secciones específicas de código.

Más detalles

Distinguir las diferentes estructuras de repetición utilizadas en problemas con ciclos: mientras, haga-mientras, repita-hasta, para.

Distinguir las diferentes estructuras de repetición utilizadas en problemas con ciclos: mientras, haga-mientras, repita-hasta, para. ESTRUCTURAS DE REPETICIÓN OBJETIVOS Aprender a construir grandes y complejos problemas a través de la ejecución repetida de una secuencia de proposiciones llamados ciclos o estructuras repetitivas. Distinguir

Más detalles

PRÁCTICA 5. SENTENCIAS DE CONTROL REPETITIVAS.

PRÁCTICA 5. SENTENCIAS DE CONTROL REPETITIVAS. PRÁCTICA 5. SENTENCIAS DE CONTROL REPETITIVAS. 1. Introducción. En esta práctica veremos todos los conceptos explicados en la segunda parte del Tema 5 de teoría: las Sentencias de Control Repetitivas,

Más detalles

INFORMÁTICA. Práctica 5. Programación en C. Grado en Ingeniería en Electrónica y Automática Industrial. Curso 2013-2014. v1.0 (05.03.

INFORMÁTICA. Práctica 5. Programación en C. Grado en Ingeniería en Electrónica y Automática Industrial. Curso 2013-2014. v1.0 (05.03. INFORMÁTICA Práctica 5. Programación en C. Grado en Ingeniería en Electrónica y Automática Industrial Curso 2013-2014 v1.0 (05.03.14) A continuación figuran una serie de ejercicios propuestos, agrupados

Más detalles

Introducción a la Computación TFA

Introducción a la Computación TFA Introducción a la Computación TFA Departamento de Informática Facultad de Ciencias Físico, Matemáticas y Naturales- UNSL Lenguaje de Diseño de Algoritmos Estructura de Control Condicional Simple y Múltiple

Más detalles

PRÁCTICA 1: INTRODUCCIÓN A LA ALGORÍTMICA BOLETIN DE PROBLEMAS RESUELTOS. (Curso 03-04)

PRÁCTICA 1: INTRODUCCIÓN A LA ALGORÍTMICA BOLETIN DE PROBLEMAS RESUELTOS. (Curso 03-04) PRÁCTICA 1: INTRODUCCIÓN A LA ALGORÍTMICA BOLETIN DE PROBLEMAS RESUELTOS. (Curso 03-04) EJERCICIOS DE ESTRUCTURAS ALTERNATIVAS : 1.- Haga el algoritmo en pseudo código que, dada una variable cuyo valor

Más detalles

Tema 4: Estructuras de Control Estructura y Contenidos

Tema 4: Estructuras de Control Estructura y Contenidos Tema 4: Estructuras de Control Estructura y Contenidos 4.1. ESTRUCTURA SECUENCIAL. 4.2. ESTRUCTURAS DE SELECCIÓN. 4.2.1. Selección simple ( if ). 4.2.2. Selección binaria ( if... ). 4.2.3. Selección múltiple

Más detalles

!!!!!!!! !!!!! Práctica!4.! Programación!básica!en!C.! ! Grado!en!Ingeniería!!en!Electrónica!y!Automática!Industrial! ! Curso!2015H2016!

!!!!!!!! !!!!! Práctica!4.! Programación!básica!en!C.! ! Grado!en!Ingeniería!!en!Electrónica!y!Automática!Industrial! ! Curso!2015H2016! INFORMÁTICA Práctica4. ProgramaciónbásicaenC. GradoenIngenieríaenElectrónicayAutomáticaIndustrial Curso2015H2016 v2.1(18.09.2015) A continuación figuran una serie de ejercicios propuestos, agrupados por

Más detalles

Estructuras de Control - Diagrama de Flujo

Estructuras de Control - Diagrama de Flujo RESOLUCIÓN DE PROBLEMAS Y ALGORITMOS Ingeniería en Computación Ingeniería en Informática UNIVERSIDAD NACIONAL DE SAN LUIS DEPARTAMENTO DE INFORMÁTICA AÑO 2015 Índice 1. Programación estructurada 2 1.1.

Más detalles

Estructura general de un programa

Estructura general de un programa Estructura general de un programa INTRODUCCION Un programa puede considerarse como una secuencia de acciones (instrucciones) que manipulan un conjunto de objetos (datos). Contendrá por tanto dos bloques

Más detalles

U i n d id d a 3. El Element os á bá i s cos de un programa

U i n d id d a 3. El Element os á bá i s cos de un programa Programación Digital U id d 3 El t bá i Unidad 3. Elementos básicos de un programa 1. Concepto de Programa Es un conjunto de instrucciones (órdenes dadas a la computadora), que producirán la ejecución

Más detalles

Estructuras Repetitivas: SENTENCIA WHILE EN MATLAB INFORMÁTICA T2 INGENIERÍA INDUSTRIAL JORNADA ESPECIAL

Estructuras Repetitivas: SENTENCIA WHILE EN MATLAB INFORMÁTICA T2 INGENIERÍA INDUSTRIAL JORNADA ESPECIAL Estructuras Repetitivas: SENTENCIA WHILE EN MATLAB INFORMÁTICA T2 INGENIERÍA INDUSTRIAL JORNADA ESPECIAL Significado La sentencia while (mientras que) se usa para que MATLAB repita un bloque de instrucciones

Más detalles

Capítulo 4 Procesos con estructuras de repetición

Capítulo 4 Procesos con estructuras de repetición Estructura de contador Capítulo 4 Procesos con estructuras de repetición Esta es una operación que incrementa en una unidad el valor almacenado en la variable c, cada vez que el flujo del diagrama pasa

Más detalles

Práctica 4: Estructuras selectivas

Práctica 4: Estructuras selectivas Fonaments d Informàtica 1r curs d Enginyeria Industrial Práctica 4: Estructuras selectivas Objetivos de la práctica Estudiar la implementación de las diferentes estructuras selectivas en MATLAB. Implementar

Más detalles

Estructuras de Repetición Repita Mientras

Estructuras de Repetición Repita Mientras Estructuras de Repetición Repita Mientras Programación digital I Escuela de Sistemas Facultad de Ingeniería Gilberto Diaz Estructuras de Repetición Las estructuras de repetición son sentencias que permiten

Más detalles

DIAGRAMAS DE FLUJO: DFD

DIAGRAMAS DE FLUJO: DFD DIAGRAMAS DE FLUJO: DFD DFD es un programa de libre disposición para ayuda al diseño e implementación de algoritmos expresados en diagramas de flujo (DF). Además incorpora opciones para el depurado de

Más detalles

Curso 0 de Informática

Curso 0 de Informática Curso 0 de Informática 2015-2016 Tema 1: Introducción a la Informática y Conceptos básicos 1 Motivación (I): En los procesos industriales, cada vez es mayor el uso de sistemas informáticos para: Monitorización,

Más detalles

Algoritmos y Diagramas de Flujo 2

Algoritmos y Diagramas de Flujo 2 Algoritmos y Diagramas de Flujo 2 Programación Java NetBeans 7.0 RPC Contenido 2.1 Algoritmo...1 Fase de creación de un algoritmo...1 Herramientas de un algoritmo...2 2.2 Diagrama de Flujo...2 Símbolos

Más detalles

Tema 2 Conceptos básicos de programación. Fundamentos de Informática

Tema 2 Conceptos básicos de programación. Fundamentos de Informática Tema 2 Conceptos básicos de programación Fundamentos de Informática Índice Metodología de la programación Programación estructurada 2 Pasos a seguir para el desarrollo de un programa (fases): Análisis

Más detalles

Introducción a los Computadores (CNM-130) Estructuras algorítmicas repetitivas

Introducción a los Computadores (CNM-130) Estructuras algorítmicas repetitivas Introducción a los Computadores (CNM-130) Estructuras algorítmicas repetitivas Alejandro Piedrahita H. Instituto de Matemáticas Facultad de Ciencias Exactas y Naturales Universidad de Antioquia Copyleft

Más detalles

Estructuras de control

Estructuras de control Estructuras de control Programación estructurada Estructuras condicionales La sentencia if La cláusula else Encadenamiento y anidamiento El operador condicional?: La sentencia switch Estructuras repetitivas/iterativas

Más detalles

Comencemos a programar con. Entrega 10. Estructuras de Control II

Comencemos a programar con. Entrega 10. Estructuras de Control II Comencemos a programar con VBA - Access Entrega 10 Estructuras de Control II Eduardo Olaz 10-2 Estructuras de Control, segunda parte Las Instrucciones While - - - Wend La estructura de bucle For Contador

Más detalles

Tecnologías en la Educación Matemática. Expresiones. Datos. Expresiones Aritméticas. Expresiones Aritméticas 19/08/2014

Tecnologías en la Educación Matemática. Expresiones. Datos. Expresiones Aritméticas. Expresiones Aritméticas 19/08/2014 Tecnologías en la Educación Matemática jac@cs.uns.edu.ar Dpto. de Ciencias e Ingeniería de la Computación UNIVERSIDAD NACIONAL DEL SUR 1 Datos Los algoritmos combinan datos con acciones. Los datos de entrada

Más detalles

Oprime click para iniciar

Oprime click para iniciar MODULO II. DESARROLLO DE SISTEMAS DE INFORMACION Oprime click para iniciar Actividades Administración de Proyectos de desarrollo de Software Estructuras algorítmicas repetitivas Ciclo de vida de un proyecto

Más detalles

Matemáticas. 1 o ESO. David J. Tarifa García. info@esobachilleratouniversidad.com.es

Matemáticas. 1 o ESO. David J. Tarifa García. info@esobachilleratouniversidad.com.es Matemáticas 1 o ESO David J. Tarifa García info@esobachilleratouniversidad.com.es 1 Matemáticas - 1 o ESO 2 Índice 1 Tema 1. Los números naturales 6 1.1 Suma de números naturales................................

Más detalles

Soporte lógico de computadoras

Soporte lógico de computadoras Soporte lógico de computadoras Software: Sistemas Operativos Lenguajes de programación Lenguajes de Programación. Clasificación Proximidad del lenguaje al que entiende el ordenador: Bajo nivel: específico

Más detalles

Tema 2. Diseño de algoritmos y programas 1. Tema 2. Diseño de algoritmos y programas

Tema 2. Diseño de algoritmos y programas 1. Tema 2. Diseño de algoritmos y programas Tema 2. Diseño de algoritmos y programas 1 Apuntes para la asignatura Informática Departamento de Lenguajes y Ciencias de la Computación UNIVERSIDAD DE MÁLAGA http://www.lcc.uma.es/personal/pepeg/mates

Más detalles

Ejercicio 1 (2 puntos. Tiempo: 25 minutos)

Ejercicio 1 (2 puntos. Tiempo: 25 minutos) Fecha de publicación de notas: jueves 18 de Julio. Fecha de revisión: viernes 19 de Julio a las 10:00h. Despacho C-209. Ejercicio 1 (2 puntos. Tiempo: 25 minutos) Se desea desarrollar un programa en C

Más detalles

DIAGRAMA DE FLUJO DE DATOS

DIAGRAMA DE FLUJO DE DATOS DIAGRAMA DE FLUJO DE DATOS AUTOR: CORDOVA NERI, TEODORO Lima Perú Córdova Neri, Teodoro 2 Diagrama de Flujo de Datos INTRODUCCIÓN La presente guía denominada DIAGRAMA DE FLUJO DE DATOS, ilustra una de

Más detalles

Estructuras de Control - Diagrama de Flujo

Estructuras de Control - Diagrama de Flujo Introducción a la Programación - Introducción a la Computación - Fundamentos de la Informática Ing. Electrónica - T.U.G. - T.U.E. - T.U.R. - T.U.W.- Prof. Tec. Elect. - T.U.T - T.U.M Área de Servicios

Más detalles

Algoritmos. Autor: José Ángel Acosta Rodríguez

Algoritmos. Autor: José Ángel Acosta Rodríguez Autor: 2006 ÍNDICE Página Índice 1 Problema 1. Movimiento de figuras geométricas.2 Problema 2. Conversión decimal a binario....3 Problema 3. Secuencias binarias..4 Problema 4. Conversión a binario a octal...

Más detalles

CONTENIDOS. 2. Entidades primitivas para el desarrollo de algoritmos.

CONTENIDOS. 2. Entidades primitivas para el desarrollo de algoritmos. Introducción a la ciencia de la computación y a la programación 1. La computadora CONTENIDOS 2. Entidades primitivas para el desarrollo de algoritmos. 3. Metodología a seguir para la resolución de problemas

Más detalles

Tema 2. Recursividad. Fundamentos de Programación II. Luís Rodríguez Baena (luis.rodriguez@upsam.net)

Tema 2. Recursividad. Fundamentos de Programación II. Luís Rodríguez Baena (luis.rodriguez@upsam.net) Fundamentos de Programación II Tema 2. Recursividad Luís Rodríguez Baena (luis.rodriguez@upsam.net) Universidad Pontificia de Salamanca (campus Madrid) Escuela Superior de Ingeniería y Arquitectura Naturaleza

Más detalles

Tema 5 Sentencias de control de flujo. Fundamentos de Informática

Tema 5 Sentencias de control de flujo. Fundamentos de Informática Tema 5 Fundamentos de Informática Sentencias de Control Tipos de sentencias de control: Comprobación lógica para bifurcar el flujo de un programa. Sentencias de control condicional o alternativo Comprobación

Más detalles

COMANDOS EN LENGUAJE DE PROGRAMACIÓN BASIC

COMANDOS EN LENGUAJE DE PROGRAMACIÓN BASIC COMANDOS EN LENGUAJE DE PROGRAMACIÓN BASIC COMANDO FUNCIÓN EJEMPLO BORRA LA PANTALLA Borra la pantalla ESCRIBE TEXTO O GRÁFICOS EN PRINT HOLA Escribe HOLA en pantalla LA PANTALLA. PRINT PRINT a Escribe

Más detalles

Informática I. While & do While

Informática I. While & do While Asignatura: Informática I Trabajo práctico Nº5 While & do While Estructura repetitiva MIENTRAS o while En C la sentencia while (condición o expresión) instrucciones; es seguramente la más utilizada. La

Más detalles

Comencemos a programar con. Entrega 09

Comencemos a programar con. Entrega 09 Comencemos a programar con VBA - Access Entrega 09 Estructuras de Control Eduardo Olaz 09-2 Estructuras de Control. Las estructuras de control son segmentos de código que nos permiten tomar decisiones

Más detalles

Tema 2: Sistemas de representación numérica

Tema 2: Sistemas de representación numérica 2.1 Sistemas de Numeración Definiciones previas Comenzaremos por definir unos conceptos fundamentales. Existen 2 tipos de computadoras: Analógicas: actúan bajo el control de variables continuas, es decir,

Más detalles

2º ITT SISTEMAS ELECTRÓNICOS 2º ITT SISTEMAS DE TELECOMUNICACIÓN 3º INGENIERÍA DE TELECOMUNICACIÓN AUTÓMATAS Y SISTEMAS DE CONTROL

2º ITT SISTEMAS ELECTRÓNICOS 2º ITT SISTEMAS DE TELECOMUNICACIÓN 3º INGENIERÍA DE TELECOMUNICACIÓN AUTÓMATAS Y SISTEMAS DE CONTROL 2º ITT SISTEMAS ELECTRÓNICOS 2º ITT SISTEMAS DE TELECOMUNICACIÓN 3º INGENIERÍA DE TELECOMUNICACIÓN AUTÓMATAS Y SISTEMAS DE CONTROL PRÁCTICA 2: INTRODUCCIÓN A MATLAB. CARACTERÍSTICAS BÁSICAS DE MATLAB Funcionalidades

Más detalles

Sentencias o instrucciones en Visual BASIC

Sentencias o instrucciones en Visual BASIC Tecnología a de la Informació Sentencias o instrucciones en Visual BASIC REM Tecnología a de la Informació REM es una sentencia no ejecutable y permite introducir comentarios en los programas. A esta práctica

Más detalles

Prácticas: Introducción a la programación en Java. Informática (1º Ingeniería Civil) Curso 2011/2012

Prácticas: Introducción a la programación en Java. Informática (1º Ingeniería Civil) Curso 2011/2012 Prácticas: Introducción a la programación en Java Informática (1º Ingeniería Civil) Índice Introducción a Java y al entorno de desarrollo NetBeans Estructura de un programa Tipos de datos Operadores Sentencias

Más detalles

UNIDAD 3: ARITMÉTICA DEL COMPUTADOR

UNIDAD 3: ARITMÉTICA DEL COMPUTADOR UNIDAD 3: ARITMÉTICA DEL COMPUTADOR Señor estudiante, es un gusto iniciar nuevamente con usted el desarrollo de esta tercera unidad. En esta ocasión, haremos una explicación más detallada de la representación

Más detalles

1 Estructura básica de un programa C++

1 Estructura básica de un programa C++ Elementos básicos de un lenguaje de alto nivel: C++ CONTENIDOS 1. Estructura básica de un programa C++. 2. Tipos de datos simples. 3. Constantes y variables en C++. Declaración. 4. Operadores y expresiones.

Más detalles

Curso de Visual Basic 6.0 - Lección 1 Area Interactiva - www.areaint.com

Curso de Visual Basic 6.0 - Lección 1 Area Interactiva - www.areaint.com LECCIÓN 6 En esta lección vamos a familiarizarnos con las estructuras de repetición, las cuales nos sirven para realizar una misma instrucción un número determinado de veces o indeterminado dependiendo

Más detalles

Fundamentos de programación

Fundamentos de programación Fundamentos de programación Objetivo: Traducir nuestras ideas a un nuevo lenguaje de programación para resolver un problema. Problema Método de resolución Lenguaje (C++) dónde está la dificultad? Solución!!...en

Más detalles

Ecuaciones de primer grado con dos incógnitas

Ecuaciones de primer grado con dos incógnitas Ecuaciones de primer grado con dos incógnitas Si decimos: "las edades de mis padres suman 120 años", podemos expresar esta frase algebraicamente de la siguiente forma: Entonces, Denominamos x a la edad

Más detalles

TEMA 5. CONTROL DE FLUJO DEL PROGRAMA. Sentencia Instrucción Expresión Operadores + Operandos Sintaxis: Sentencia ;

TEMA 5. CONTROL DE FLUJO DEL PROGRAMA. Sentencia Instrucción Expresión Operadores + Operandos Sintaxis: Sentencia ; TEMA 5. CONTROL DE FLUJO DEL PROGRAMA 5.1 Sentencias Una sentencia es una expresión seguida de un punto y coma. Sentencia Instrucción Expresión Operadores + Operandos Sintaxis: Sentencia ; El ; es obligatorio

Más detalles

Unidad 2: Metodología de la Programación 1 Unidad 2 METODOLOGÍA DE LA PROGRAMACIÓN Desarrollo de la unidad : 27 h

Unidad 2: Metodología de la Programación 1 Unidad 2 METODOLOGÍA DE LA PROGRAMACIÓN Desarrollo de la unidad : 27 h Unidad 2: Metodología de la Programación 1 Unidad 2 METODOLOGÍA DE LA PROGRAMACIÓN Desarrollo de la unidad : 27 h Prácticas y Ejercicios : Diseñar con el Word ordinogramas y organigramas Problemas con

Más detalles

Informática y Programación Escuela de Ingenierías Industriales y Civiles Grado en Ingeniería en Ingeniería Química Curso 2010/2011

Informática y Programación Escuela de Ingenierías Industriales y Civiles Grado en Ingeniería en Ingeniería Química Curso 2010/2011 Módulo 1. Fundamentos de Computadores Informática y Programación Escuela de Ingenierías Industriales y Civiles Grado en Ingeniería en Ingeniería Química Curso 2010/2011 1 CONTENIDO Tema 1. Introducción

Más detalles

Estructuras de Control en C

Estructuras de Control en C Departamento de Informática Universidad Técnica ederico Santa María Estructuras de Control en C Programación de Computadores Profesor Teddy Alfaro Secuencia El secuencialismo está inserto en todo programa

Más detalles

Diseño de algoritmos

Diseño de algoritmos Diseño de algoritmos Jose Jesus García Rueda. Adaptado de El algoritmo, una iniciación a la programación (http://www.desarrolloweb.com/manuales/67/ http://www.desarrolloweb.com/manuales/67/) ) y de Diseño

Más detalles

DÍGITOS DE CONTROL: APLICACIONES DE LA ARITMÉTICA DE NÚMEROS ENTEROS A LA VIDA REAL

DÍGITOS DE CONTROL: APLICACIONES DE LA ARITMÉTICA DE NÚMEROS ENTEROS A LA VIDA REAL DÍGITOS DE CONTROL: APLICACIONES DE LA ARITMÉTICA DE NÚMEROS ENTEROS A LA VIDA REAL Autores: Cristina Steegmann Pascual (csteegmann@uoc.edu), Ángel A. Juan Pérez (ajuanp@uoc.edu). ESQUEMA DE CONTENIDOS

Más detalles

ha llevado el registro de varios tanques de gasolina, desarrolle un programa que lea los kilómetros manejados y los litros de gasolina utilizados en

ha llevado el registro de varios tanques de gasolina, desarrolle un programa que lea los kilómetros manejados y los litros de gasolina utilizados en Ejercicios de programación Tema: Métodos y mensajes Instrucciones: Elabore los programas que se indican utilizando en cada uno al menos un método o método miembro diferente al main. 1. Diseñar un método

Más detalles

Lenguaje C Bucles, Condicionales, operadores y Algoritmos.

Lenguaje C Bucles, Condicionales, operadores y Algoritmos. Lenguaje C Bucles, Condicionales, operadores y Algoritmos. Omar Andrés Zapata Mesa Grupo de Fenomenología de Interacciones Fundamentales, (Gfif) Universidad de Antioquia Operadores Los operadores son aquellos

Más detalles

FUNDAMENTOS DE PROGRAMACION

FUNDAMENTOS DE PROGRAMACION E.A.P. Sistemas e Informática FUNDAMENTOS DE PROGRAMACION Ing. MIRKO MANRIQUE RONCEROS PRIMERA EDICION CHIMBOTE - PERU Página 1 de 63 INDICE INTRODUCCION FUNDAMENTOS BÁSICOS DE ALGORITMOS Elementos básicos

Más detalles

Tema 2. Software. Informática (1º Ingeniería Civil) jcarmur@unex.es

Tema 2. Software. Informática (1º Ingeniería Civil) jcarmur@unex.es Tema 2. Software Informática (1º Ingeniería Civil) Curso 2011/2012 Javier Carmona Murillo jcarmur@unex.es Índice Introducción. Programas e instrucciones. Tipos y estructuras de datos. Algoritmos. Proceso

Más detalles

ETS Caminos Santander. Curso 2012. Ejercicios de introducción a la programación.

ETS Caminos Santander. Curso 2012. Ejercicios de introducción a la programación. Ejercicio 1. Saludo. El programa preguntará el nombre al usuario y a continuación le saludará de la siguiente forma "Hola, NOMBRE" donde NOMBRE es el nombre del usuario. Ejercicio 2. Suma. El programa

Más detalles

Ejercicios resueltos con acumuladores. Pseudocódigo y diagramas de flujo. Bucle desdesiguiente (for-next). (CU00160A)

Ejercicios resueltos con acumuladores. Pseudocódigo y diagramas de flujo. Bucle desdesiguiente (for-next). (CU00160A) aprenderaprogramar.com Ejercicios resueltos con acumuladores. Pseudocódigo y diagramas de flujo. Bucle desdesiguiente (for-next). (CU00160A) Sección: Cursos Categoría: Curso Bases de la programación Nivel

Más detalles

TEMA 3: EL LENGUAJE C: PRESENTACIÓN

TEMA 3: EL LENGUAJE C: PRESENTACIÓN TEMA 3: EL LENGUAJE C: PRESENTACIÓN Historia del lenguaje C Características del lenguaje C Estructura de un programa en C El editor de textos: elementos Funciones: de usuario y de librería Librerías de

Más detalles

Hoja de problemas Estructuras de Control

Hoja de problemas Estructuras de Control Departamento de Estadística, I.O. y Computación Ingeniería Técnica Industrial - Electrónica Industrial Fundamentos de Informática Hoja de problemas Estructuras de Control 1. Cuál es el efecto de las siguientes

Más detalles

Escuela Politécnica Superior de Ingeniería Departamento de Ingeniería Informática

Escuela Politécnica Superior de Ingeniería Departamento de Ingeniería Informática Escuela Politécnica Superior de Ingeniería Departamento de Ingeniería Informática Fundamentos de la informática 2. Algoritmos, diagramas de flujo y pseudocódigo Contenido Algoritmos Diagramas de flujo

Más detalles

Operaciones combinadas

Operaciones combinadas Operaciones combinadas PROPIEDAD DISTRIBUTIVA DEL PRODUCTO RESPECTO DE LA SUMA La propiedad distributiva permite transformar un producto en una suma y viceversa. En general, si a, b y c son números enteros

Más detalles

Operaciones básicas, fórmulas, referencias absolutas, relativas y mixtas.

Operaciones básicas, fórmulas, referencias absolutas, relativas y mixtas. Módulo 3 Herramientas de Cómputo Operaciones básicas, fórmulas, referencias absolutas, relativas y mixtas. Operaciones Básicas Las operaciones básicas que se realizan en una hoja de cálculo son: Seleccionar

Más detalles

MANUAL BASICO DE INSTRUCCIONES Y COMANDOS SMART DFD 1.0

MANUAL BASICO DE INSTRUCCIONES Y COMANDOS SMART DFD 1.0 MANUAL BASICO DE INSTRUCCIONES Y COMANDOS SMART DFD 1.0 Smart DFD es un software desarrollado por el grupo Smart, de la Universidad del Magdalena (Santa Marta, Colombia) para apoyar la enseñanza de la

Más detalles

Arreglos. // Incluir E/S y Librerías Standard #include #include

Arreglos. // Incluir E/S y Librerías Standard #include <stdlib.h> #include <stdio.h> Arreglos Introducción. En los temas anteriores se han estudiado los diferentes tipos de datos simples de C++, usados para representar valores simples como enteros, reales o caracteres. Sin embargo, en

Más detalles

EJERCICIOS SOBRE : NÚMEROS ENTEROS

EJERCICIOS SOBRE : NÚMEROS ENTEROS 1.- Magnitudes Absolutas y Relativas: Se denomina magnitud a todo lo que se puede medir cuantitativamente. Ejemplo: peso de un cuerpo, longitud de una cuerda, capacidad de un recipiente, el tiempo que

Más detalles

Ejemplos de conversión de reales a enteros

Ejemplos de conversión de reales a enteros Ejemplos de conversión de reales a enteros Con el siguiente programa se pueden apreciar las diferencias entre las cuatro funciones para convertir de reales a enteros: program convertir_real_a_entero print

Más detalles

PHP y MySQL. Indice: Switch Bucles For While do...while

PHP y MySQL. Indice: Switch Bucles For While do...while PHP y MySQL Indice: Switch Bucles For While do...while Switch switch...case es otra opción para trabajar con condiciones. Y suplanta al if, cuando lo único que se quiere hacer es comparar si son iguales

Más detalles

Microsoft Excel. LA HOJA DE TRABAJO El gran área formada por cuadrículas constituye la hoja de trabajo de la hoja de cálculo.

Microsoft Excel. LA HOJA DE TRABAJO El gran área formada por cuadrículas constituye la hoja de trabajo de la hoja de cálculo. Microsoft Excel Diferentes partes de la pantalla Veamos ahora las diferentes partes de la pantalla comenzando por la parte superior. La Barra de Título. La barra azul de arriba muestra el nombre del programa

Más detalles

UNIDAD 5. ESTRUCTURAS DINÁMICAS Y ESTÁTICAS DE ALMACENAMIENTO DE DATOS.

UNIDAD 5. ESTRUCTURAS DINÁMICAS Y ESTÁTICAS DE ALMACENAMIENTO DE DATOS. UNIDAD 5. ESTRUCTURAS DINÁMICAS Y ESTÁTICAS DE ALMACENAMIENTO DE DATOS. 5.1.- SECUENCIA En este caso, las instrucciones se ejecutan una después de la otra sin omitir ninguna de ellas. La sintaxis para

Más detalles

Estructuras de repetición hacer-mientras y repita hasta

Estructuras de repetición hacer-mientras y repita hasta Estructuras de repetición hacer-mientras y repita hasta Programación 1 Cátedra de Programación Departamento de Computación Escuela de Ingeniería de Sistemas Hacer mientras Diagrama de flujo Acciones S1

Más detalles

MANUAL DE USO DE SMART DFD

MANUAL DE USO DE SMART DFD MANUAL DE USO DE SMART DFD Computación (620033) Ayudantes: Leonardo Muñoz Erik Pinto lmmunoz@alumnos.ubiobio.cl erpinto@alumnos.ubiobio.cl http://ayudantiasubb.wordpress.com Este es un pequeño manual de

Más detalles

Estructura y Tecnología de Computadores (ITIG) Luis Rincón Córcoles José Ignacio Martínez Torre Ángel Serrano Sánchez de León.

Estructura y Tecnología de Computadores (ITIG) Luis Rincón Córcoles José Ignacio Martínez Torre Ángel Serrano Sánchez de León. Estructura y Tecnología de Computadores (ITIG) Luis Rincón Córcoles José Ignacio Martínez Torre Ángel Serrano Sánchez de León Programa 1. Introducción. 2. Operaciones lógicas. 3. Bases de la aritmética

Más detalles

Informática. Algoritmos. Baños García Yesenia, Lic. Comp. Hernández Nájera Aracely, Lic. Comp. Enero 2012.

Informática. Algoritmos. Baños García Yesenia, Lic. Comp. Hernández Nájera Aracely, Lic. Comp. Enero 2012. Informática Algoritmos Baños García Yesenia, Lic. Comp. Hernández Nájera Aracely, Lic. Comp. Enero 2012. El presente trabajo muestra la metodología para dar solución a un problema específico, aplicando

Más detalles

Divisibilidad y números primos

Divisibilidad y números primos Divisibilidad y números primos Divisibilidad En muchos problemas es necesario saber si el reparto de varios elementos en diferentes grupos se puede hacer equitativamente, es decir, si el número de elementos

Más detalles

Universidad Metropolitana Castro Carazo Prof. Ing. Patricia Vargas. Material de apoyo Semana #2 PROGRAMACIÓN II

Universidad Metropolitana Castro Carazo Prof. Ing. Patricia Vargas. Material de apoyo Semana #2 PROGRAMACIÓN II Prof. Ing. Patricia Vargas 1 Universidad Metropolitana Castro Carazo Prof. Ing. Patricia Vargas Material de apoyo Semana #2 PROGRAMACIÓN II Agenda 1. Definición de variables locales y públicas. 2. Declaraciones

Más detalles

Karel y Recursión. I. Entendiendo la Recursión

Karel y Recursión. I. Entendiendo la Recursión I. Entendiendo la Recursión Karel y Recursión Recursión es la forma en la cual se especifica un proceso basado en su propia definición. Siendo un poco más precisos, y para evitar el aparente círculo sin

Más detalles

2013/06/11 Matemáticas I (Ed. Primaria) Curso 2012-13 Jun. Extr. Apellidos: Nombre: N :

2013/06/11 Matemáticas I (Ed. Primaria) Curso 2012-13 Jun. Extr. Apellidos: Nombre: N : PARTE I 1h 15 minutos Dpto. Física y Matemáticas 2013/06/11 Matemáticas I (Ed. Primaria) Curso 2012-13 Jun. Extr. Apellidos: Nombre: N : Resuelve las siguientes cuestiones en el espacio reservado para

Más detalles

Definición 1.1.1. Sea K un cuerpo. Un polinomio en x, con coeficientes en K es toda expresión del tipo

Definición 1.1.1. Sea K un cuerpo. Un polinomio en x, con coeficientes en K es toda expresión del tipo POLINOMIOS 1.1. DEFINICIONES Definición 1.1.1. Sea K un cuerpo. Un polinomio en x, con coeficientes en K es toda expresión del tipo p(x) = a i x i = a 0 + a 1 x + a 2 x 2 + + a n x n + ; a i, x K; n N

Más detalles

Algoritmos. Tema 6. 6.1 Algoritmos y pseudocódigo

Algoritmos. Tema 6. 6.1 Algoritmos y pseudocódigo Tema 6 Algoritmos Una vez que se tiene una idea de cual es la estructura y funcionamiento de la computadora digital es posible preparar el camino para lograr su programación. En primer lugar hay que dejar

Más detalles

PRÁCTICA N 2 SISTEMAS DE NUMERACIÓN

PRÁCTICA N 2 SISTEMAS DE NUMERACIÓN PRÁCTICA N 2 SISTEMAS DE NUMERACIÓN Ejercicio 1. Diseñar una planilla EXCEL que tome como dato de entrada un número entero y devuelva la representación en base 2. Testearla con los números 23, 245, 673,

Más detalles

Introducción a la Computación

Introducción a la Computación UNIVERSIDAD RAFAEL BELLOSO CHACÍN FACULTAD DE INGENIERIA INTRODUCCIÓN A LA COMPUTACION UNIDAD II: DATOS, ALGORITMOS Y PSEUDOCODIGOS http://www.urbe.edu/info-consultas/web-profesor/12697883/ ALGORITMO Un

Más detalles

Tema 9. Vectores y Matrices

Tema 9. Vectores y Matrices Tema 9. Vectores y Matrices OBJETIVO En temas anteriores hemos declarado variables simples de tipo int, float, o de cualquier otro tipo simple. A menudo necesitaremos declarar una colección de variables,

Más detalles

Resolución de Problemas

Resolución de Problemas Resolución de Problemas con algoritmos Colaboratorio de Computación Avanzada (CNCA) 2015 1 / 27 Contenidos 1 Introducción 2 Elementos de algoritmos Elementos Variables Estructuras de Control Condicionales

Más detalles

Estructuras de repetición

Estructuras de repetición Estructuras de repetición Fundamentos de Programación Fundamentos de Programación I FP-PFI Curso 2005-2006 1 Estructuras iterativos Sentencia for for(inic; cond; increm) sentencia1; sentencia2; Sentencia

Más detalles

Universidad Nacional del Santa F A C U L T A D D E I N G E N I E R I A E.A.P. Ingeniería de Sistemas e Informática NETBEANS 7.0

Universidad Nacional del Santa F A C U L T A D D E I N G E N I E R I A E.A.P. Ingeniería de Sistemas e Informática NETBEANS 7.0 Universidad Nacional del Santa F A C U L T A D D E I N G E N I E R I A E.A.P. Ingeniería de Sistemas e Informática NETBEANS 7.0 PROYECTO DE ESTRUCTURA REPETITIVA DO WHILE A c o n t i n u a c i ó n r e

Más detalles

UNIDAD Nº 1: 1. SISTEMAS DE NUMERACION. Formalizado este concepto, se dirá que un número X viene representado por una cadena de dígitos:

UNIDAD Nº 1: 1. SISTEMAS DE NUMERACION. Formalizado este concepto, se dirá que un número X viene representado por una cadena de dígitos: UNIDAD Nº 1: TECNICATURA EN INFORMATICA UNLAR - CHEPES 1.1. INTRODUCCION 1. SISTEMAS DE NUMERACION El mundo del computador es un mundo binario. Por el contrario, el mundo de la información, manejada por

Más detalles

Deseamos, pues, al alumno el mayor de los éxitos en su intento.

Deseamos, pues, al alumno el mayor de los éxitos en su intento. INTRODUCCIÓN Todo debería hacerse tan sencillo como sea posible, pero no más Albert Einstein, físico Cuanto más trabajo y practico, más suerte parezco tener Gary Player, jugador profesional de golf E studiar

Más detalles

Temario detallado. Conceptos generales de lenguajes y compiladores. Proceso de compilación de un programa en C++ bajo Code::Blocks

Temario detallado. Conceptos generales de lenguajes y compiladores. Proceso de compilación de un programa en C++ bajo Code::Blocks Temario detallado Programación básica en C++ Conceptos generales de lenguajes y compiladores Proceso de compilación de un programa en C++ bajo Code::Blocks Estructura básica de un programa en C++ Análisis

Más detalles

ESTRUCTURA DE DATOS: ARREGLOS

ESTRUCTURA DE DATOS: ARREGLOS ESTRUCTURA DE DATOS: ARREGLOS 1. Introduccion 2. Arreglos - Concepto - Caracteristicas 3. Arreglos Unidimensionales 4. Arreglos Bidimensionales 5. Ventajas del uso de arreglos 6. Ejemplo 1. Introducción

Más detalles

ESCALARES, VECTORES Y MATRICES

ESCALARES, VECTORES Y MATRICES ESCALARES, VECTORES Y MATRICES MATRIZ Al resolver problemas de ingeniería, es importante poder visualizar los datos relacionados con el problema. A veces los datos consisten en un solo número, como el

Más detalles

De aquí sale el proyecto MACsyma (MAC s SYmbolic MAnipulator)

De aquí sale el proyecto MACsyma (MAC s SYmbolic MAnipulator) El proyecto Matemáticas y Computación (MAC) se inicia en la década de los años 60 en el MIT (con el apoyo financiero de los Departamentos de Defensa y Energía de los EE.UU.) para atender sus necesidades

Más detalles

construcción de programas Prof. Eliana Guzmán U.

construcción de programas Prof. Eliana Guzmán U. Unidad II. Metodología para la construcción de programas Prof. Eliana Guzmán U. Semestre: A-2015 Introducción Resolver un problema con una computadora conduce a la escritura de un programa y a su ejecución.

Más detalles

1 La Resolución de Problemas utilizando la Computadora

1 La Resolución de Problemas utilizando la Computadora La Resolución de Problemas utilizando la Computadora Lissette Alvarez Abril-Julio, 2004 El Computador es una máquina que no puede trabajar por si sola, únicamente realiza aquellas órdenes que el hombre

Más detalles

Complemento Microsoft Mathematics

Complemento Microsoft Mathematics Complemento Microsoft Mathematics El complemento Microsoft Mathematics es un conjunto de herramientas que se pueden usar para realizar operaciones matemáticas y trazado de gráficas con expresiones o ecuaciones

Más detalles

Herramienta computacional. http://raptor.martincarlisle.com/

Herramienta computacional. http://raptor.martincarlisle.com/ Herramienta computacional http://raptor.martincarlisle.com/ 1 Qué es RAPTOR? Presenta un entorno de desarrollo de la programación visual basado en diagramas de flujo. Su lenguaje minimiza la sintaxis que

Más detalles

Sistemas de Numeración

Sistemas de Numeración UNIDAD Sistemas de Numeración Introducción a la unidad Para la mayoría de nosotros el sistema numérico base 0 aparentemente es algo natural, sin embargo si se establecen reglas de construcción basadas

Más detalles